prompter_iaa 0.0.1

My project


import 'package:prompter_iaa/prompter_iaa.dart';

void main() {

  final options = [
    new Option("I want red", "#f00"),
    new Option("I want blue", "#oof"),

  final prompter = new Prompter();

  String colorCode = prompter.askMultiple("Select a color", options);
  bool answer = prompter.askBinary("Do you like this lib?");


// Option represents 1 answer to given question
// Options class - class because code tied to each option
// Prompter class
// Terminal class ensures printing out to terminal
// automatically create a property for us
// print options will take a list of option objects

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  prompter_iaa: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:prompter_iaa/prompter_iaa.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK 3.0.0