prompter_elhe 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

Prompter cli #

This library is to create a prompter on your project

Changes #

v0.0.2 #

Changing askMultiple return type to dynamic.

0.0.3 #

Adding the CHANGELOG.md file.

0.0.2 #

Changing askMultiple return type (String) to a dynamic type.

0.0.1 #

Initial version, created by Erick Heredia

example/main.dart

import 'package:prompter_elhe/prompter_elhe.dart';

void main(List<String> args) {
  List<Option> options = [
    Option(label: "I want red", value: "#f00"),
    Option(label: "I want blue", value: "#00f")
  ];

  var prompter = Prompter();

  String colorCode = prompter.askMultiple(
    prompt: "Select a color",
    options: options,
  );

  bool answer = prompter.askBinary(prompt: "Do you like this lib?");

  print(colorCode);
  print(answer);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_elhe: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_elhe/prompter_elhe.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Oct 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_elhe/prompter_elhe.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

11 out of 11 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0