prompt_dialog 1.0.16 copy "prompt_dialog: ^1.0.16" to clipboard
prompt_dialog: ^1.0.16 copied to clipboard

Prompt Dialog Widget JS-LIKE for Flutter. Use prompt dialog easy and simple for your flutter app.

example/main.dart

import 'package:flutter/material.dart';

import 'package:prompt_dialog/prompt_dialog.dart';

void main() {
  runApp(const MyApp());
}

class MyApp extends StatelessWidget {
  const MyApp({Key? key}) : super(key: key);

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: const MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  const MyHomePage({Key? key, required this.title}) : super(key: key);

  final String title;

  @override
  State<MyHomePage> createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: ElevatedButton(
          child: const Text('Prompt Dialog'),
          onPressed: () async {
            return print(await prompt(context));
          },
        ),
      ),
    );
  }
}
20
likes
160
pub points
90%
popularity

Publisher

unverified uploader

Prompt Dialog Widget JS-LIKE for Flutter. Use prompt dialog easy and simple for your flutter app.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on prompt_dialog