progressable_button 1.1.3

  • Readme
  • Changelog
  • Installing
  • 55

progressable_button #

A progressable button using streams

[1.0.0] #

  • Initial release

[1.0.1] #

  • Code refactor

[1.0.2] #

  • Bool verification fix

[1.1.0] #

  • Possibility to add a gradient as background

[1.1.1] #

  • Fix to force all colors as gradients in case there is a single one gradient in constructor

[1.1.2] #

  • Fix to force all colors as gradients in case there is a single one gradient in constructor

[1.1.3] #

  • Fix to force all colors as gradients in case there is a single one gradient in constructor

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  progressable_button: ^1.1.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:progressable_button/progressable_button.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
24
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:progressable_button/progressable_button.dart that imports:
  • package:vibrate/vibrate.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:progressable_button/progressable_button.dart that imports:
  • package:vibrate/vibrate.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:progressable_button/progressable_button.dart that imports:
  • package:vibrate/vibrate.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:progressable_button/progressable_button.dart that imports:
  • package:vibrate/vibrate.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • progressable_button that is a package requiring null.

Health issues and suggestions

Document public APIs. (-0.14 points)

66 out of 68 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/progressable_button.dart. (-1 points)

Analysis of lib/progressable_button.dart reported 2 hints:

line 90 col 47: 'body1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is bodyText2. This feature was deprecated after v1.13.8..

line 91 col 47: 'body2' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is bodyText1. This feature was deprecated after v1.13.8..

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and progressable_button.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
vector_math ^2.0.8 2.0.8 2.1.0-nullsafety
vibrate ^0.0.4 0.0.4
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
Dev dependencies
flutter_test