progress_hud 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 47

progress_hud #

A clean and lightweight progress HUD for your Flutter app

Example #

return new Scaffold(
  appBar: new AppBar(
    // Here we take the value from the MyHomePage object that was created by
    // the App.build method, and use it to set our appbar title.
    title: new Text(widget.title),
  ),
  body: new Stack(
    children: <Widget>[
      new Text(
        'A clean and lightweight progress HUD for your Flutter app'
      ),
      new ProgressHUD(
        backgroundColor: Colors.black12,
        color: Colors.orange
      )
    ],
  )
);

Showcase #

[0.0.1]

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  progress_hud: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:progress_hud/progress_hud.dart';
  
Version Uploaded Documentation Archive
1.1.0 Sep 1, 2018 Go to the documentation of progress_hud 1.1.0 Download progress_hud 1.1.0 archive
1.0.0 May 28, 2018 Go to the documentation of progress_hud 1.0.0 Download progress_hud 1.0.0 archive
0.2.2 Mar 14, 2018 Go to the documentation of progress_hud 0.2.2 Download progress_hud 0.2.2 archive
0.1.2 Mar 12, 2018 Go to the documentation of progress_hud 0.1.2 Download progress_hud 0.1.2 archive
0.1.1 Mar 12, 2018 Go to the documentation of progress_hud 0.1.1 Download progress_hud 0.1.1 archive
0.0.1 Mar 11, 2018 Go to the documentation of progress_hud 0.0.1 Download progress_hud 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0