progress 0.1.0+1

  • Readme
  • Changelog
  • Installing
  • 0

progress #

Compute progress of a long-running process.

pub package Build Status Coverage Status

This package is platform agnostic, and will work equally well for command-line applications (CLI), mobile applications on Flutter, and web applications written in Dart.

Warning: This is not an official Google or Dart project.

Installation #

  progress: ^0.1.0

Usage #

To produce a Stream<Moment>, use an Updater:

// A simple stub of reporting 50% progress, then 100%.
Stream<Moment> progress() {
  final updater = new Updater(100);
  scheduleMicrotask(() {
    scheduleMicrotask(() {
  return updater;

To use an existing Stream<num> of current values, use asProgress:

asProgress(currentValues, totalValue);

0.1.0+1 #

  • Update

0.1.0 #

  • Initial commit.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  progress: ^0.1.0+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:progress/progress.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0