print_color 1.0.1+6

  • Readme
  • Changelog
  • Example
  • Installing
  • new74

print_color #

simply organize debugging

screenshot

usage #

  • import import 'package:print_color/print_color.dart';
  • just Print.green('someText')

example #

import 'package:print_color/print_color.dart';

Print.white('white');
Print.black('black');
Print.cyan('cyan');
Print.blue('blue');
Print.green('green');
Print.red('red');
Print.magenta('magenta');
Print.yellow('yellow');

colors #

  • white
  • black
  • cyan
  • blue
  • green
  • red
  • magenta
  • yellow

Author #

Mohamed Sayed

  • LinkedIn   Fork   Star   Watches
  • Plugin   Example

My Plugins #

1.0.1+6 #

  • Enhanced Documentation
  • Fixed Tiny Bug
  • Fixed iOS Bug

1.0.0 #

  • Now it's ready

0.1.0 #

  • Beta Version

example/README.md

print_color_example #

Example dir

import 'package:flutter/material.dart';
import 'package:print_color/print_color.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('print_color'),
        ),
        body: Center(
            child: OutlineButton(
          onPressed: () {
            Print.white('white');
            Print.black('black');
            Print.cyan('cyan');
            Print.blue('blue');
            Print.green('green');
            Print.red('red');
            Print.magenta('magenta');
            Print.yellow('yellow');
          },
          child: Text('Click Me For Magic'),
        )),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  print_color: ^1.0.1+6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:print_color/print_color.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
ansicolor ^1.0.2 1.0.2
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8