print_beautiful 0.0.1+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 46

print() function that helps to understand the structure of the object printed #

See example/main.dart #


0.0.1+2 #

  • Minor fixes

0.0.1+1 #

  • Minor fixes

0.0.1 #

  • Minor fixes

0.0.0 #

  • Initial release


import 'package:print_beautiful/print_beautiful.dart';

main() {
  final obj = {
    'a': 'a',
    'b': 'b',
    'c': [1, 2, 3],
    'd': {'a1': 'a1'},
    'e': 1,
    'f': true,

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  print_beautiful: ^0.0.1+2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:print_beautiful/print_beautiful.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 25, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/utilities.dart. (-0.50 points)

Analysis of lib/src/utilities.dart reported 1 hint:

line 167 col 1: The declaration '_test' isn't referenced.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (equatable).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
ansicolor ^1.0.2 1.0.2
equatable ^0.2.0 0.2.6 1.1.1
meta ^1.1.6 1.1.8
Transitive dependencies
collection 1.14.12