presentation 0.0.11

  • Readme
  • Changelog
  • Example
  • Installing
  • 64

presentation #

Set of tools providing presentation capabilities (transitions, animations, navigation,...) to a Flutter application

[0.0.11] #

Allowing code size change

[0.0.10+3] #

Fixing keyboard navigation on Windows

[0.0.10+2] #

Updating to Flutter 1.19.0-4.1.

[0.0.10+1] #

Adding style to Markdown.

[0.0.10] #

Updating flutter version and other cleanup.

[0.0.9] #

Adding simple Markdown editor.

[0.0.8] #

Removing dependency on flutter_localizations

[0.0.7] #

[0.0.6] #

  • Added enableMouseNavigation - enables/disables navigation between slides with single and double tap
  • Fixed keyboard navigation on Windows in Flutter 1.10.2 and newer

[0.0.5] #

  • Fixed keyboard navigation on MacOs - by PakoSt

[0.0.4] #

Adding new widgets:

  • WrappedAnimatedBuilder - AnimatedBuilder with animation exposed for connivance
  • AnimatedParallaxImage - used to create infinite parallax animation in the background
  • AnimationMode - similar to TickerMode but renders first frame of widget
  • RevealEffect - reveals it child with an animation effect

[0.0.3] #

  • Supporting key up and down for presentation navigation

[0.0.2] #

  • Modularising library

[0.0.1] #

  • Initial release - still alpha

example/lib/main.dart

import 'package:flutter/foundation.dart';
import 'package:flutter/material.dart';
import 'package:presentation/presentation.dart';

void main() {
  // Enables rendering on desktop
  debugDefaultTargetPlatformOverride = TargetPlatform.fuchsia;
  runApp(const PresentationExample());
}

class PresentationExample extends StatefulWidget {
  const PresentationExample({Key key}) : super(key: key);
  @override
  _PresentationExampleState createState() => _PresentationExampleState();
}

class _PresentationExampleState extends State<PresentationExample> {
  PageController _controller;
  PresentationController _presentationController;

  @override
  void initState() {
    super.initState();
    _controller = PageController();
    _presentationController = PresentationController(controller: _controller);
  }

  @override
  void dispose() {
    _presentationController.dispose();
    _controller.dispose();
    super.dispose();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Presentation(
        controller: _controller,
        presentationController: _presentationController,
        children: const [
          SimplePage('1'),
        ],
      ),
    );
  }
}

class SimplePage extends StatelessWidget {
  const SimplePage(
    this.text, {
    Key key,
  }) : super(key: key);

  final String text;

  @override
  Widget build(BuildContext context) {
    return Container();
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  presentation: ^0.0.11

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:presentation/presentation.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
56
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Health issues and suggestions

Fix lib/src/presentation_controller.dart. (-43.75 points)

Analysis of lib/src/presentation_controller.dart failed with 2 errors:

line 71 col 24: The name 'RawKeyEventDataWindows' isn't defined, so it can't be used in an 'is' expression.

line 72 col 19: The getter 'keyCode' isn't defined for the type 'RawKeyEventData'.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test