pref 2.4.0 icon indicating copy to clipboard operation
pref: ^2.4.0 copied to clipboard

Create Preference Screens easily with advanced features and sub-pages

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add pref

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  pref: ^2.4.0

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:pref/pref.dart';
25
likes
130
pub points
85%
popularity

Publisher

shield icon for verified publishersnfet.net

Create Preference Screens easily with advanced features and sub-pages

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, logging, shared_preferences

More

Packages that depend on pref