powerpack 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new13

powerpack #

A new flutter plugin project.

Example #

import 'package:flutter/material.dart';
import 'package:powerpack/powerpack.dart';

import 'plugins/desktop/desktop.dart';

void main() {
  setTargetPlatformForDesktop();
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      theme: ThemeData.light().copyWith(
        accentColor: Colors.red,
      ),
      home: HomeScreen(),
    );
  }
}

class HomeScreen extends StatelessWidget {
  const HomeScreen({
    Key key,
  }) : super(key: key);

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: const Text('Plugin example app').onPressed(
          onTap: () => print('AppBar Tapped!'),
        ),
      ),
      drawer: Drawer(
        child: SafeArea(
            child: Container(
          child: Column(
            children: <Widget>[
              ListTile(
                leading: Icon(Icons.home),
                title: Text('Home'),
              ),
              ListTile(
                leading: Icon(Icons.search),
                title: Text('Search'),
              ),
              ListTile(
                leading: Icon(Icons.settings),
                title: Text('Settings'),
              ),
            ],
          ),
        ).asScrollable),
      ),
      endDrawer: Drawer(
        child: SafeArea(
            child: Container(
          child: Column(
            children: <Widget>[
              SwitchListTile.adaptive(
                title: Text('Dark Mode'),
                value: true,
                onChanged: (val) {},
              ),
            ],
          ),
        ).asScrollable),
      ),
      body: Center(
        child: Text('Demo'),
      ),
      floatingActionButton: FloatingActionButton(
        backgroundColor: Theme.of(context).accentColor,
        child: Icon(Icons.info),
        onPressed: () {},
      ),
    ).asResponsive();
  }
}

0.0.1 #

  • TODO: Describe initial release.

example/README.md

powerpack_example #

import 'package:flutter/material.dart';
import 'package:powerpack/powerpack.dart';

import 'plugins/desktop/desktop.dart';

void main() {
  setTargetPlatformForDesktop();
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      theme: ThemeData.light().copyWith(
        accentColor: Colors.red,
      ),
      home: HomeScreen(),
    );
  }
}

class HomeScreen extends StatelessWidget {
  const HomeScreen({
    Key key,
  }) : super(key: key);

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: const Text('Plugin example app').onPressed(
          onTap: () => print('AppBar Tapped!'),
        ),
      ),
      drawer: Drawer(
        child: SafeArea(
            child: Container(
          child: Column(
            children: <Widget>[
              ListTile(
                leading: Icon(Icons.home),
                title: Text('Home'),
              ),
              ListTile(
                leading: Icon(Icons.search),
                title: Text('Search'),
              ),
              ListTile(
                leading: Icon(Icons.settings),
                title: Text('Settings'),
              ),
            ],
          ),
        ).asScrollable),
      ),
      endDrawer: Drawer(
        child: SafeArea(
            child: Container(
          child: Column(
            children: <Widget>[
              SwitchListTile.adaptive(
                title: Text('Dark Mode'),
                value: true,
                onChanged: (val) {},
              ),
            ],
          ),
        ).asScrollable),
      ),
      body: Center(
        child: Text('Demo'),
      ),
      floatingActionButton: FloatingActionButton(
        backgroundColor: Theme.of(context).accentColor,
        child: Icon(Icons.info),
        onPressed: () {},
      ),
    ).asResponsive();
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  powerpack: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:powerpack/powerpack.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
43
Overall:
Weighted score of the above. [more]
13
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms:

Error(s) prevent platform classification:

Make sure flutter format successfully runs on your package's source files.

Analysis issues and suggestions

Make sure flutter format successfully runs on your package's source files.

Running flutter format failed with the following output:

Exception: dartfmt on lib/ failed with exit code 65
Could not format because the source could not be parsed:

line 4, column 1 of lib/src/scaffold.dart: This requires the 'extension-methods' experiment to be enabled.
  ╷
4 │ extension ScaffoldUtils on Scaffold {
  │ ^^^^^^^^^
  ╵
line 4, column 28 of lib/src/scaffold.dart: Functions must have an explicit list of parameters.
  ╷

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.5.0.
 
 Because powerpack requires SDK version >=2.6.0-dev.8.0.flutter-a61c775db8 <3.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Make sure flutter format successfully runs on your package's source files.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0-dev.8.0.flutter-a61c775db8 <3.0.0