Potrace package for Flutter #
Flutter port of Potrace polygon tracer.
1.0.1 - May 10, 2019 #
- Upgrade image package to 2.0.8
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: potrace: ^1.0.1+1
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.1
- pana: 0.12.21
- Flutter: 1.9.1+hotfix.4
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/potrace.dart. (-1.49 points)
lib/potrace.dart reported 3 hints:
line 14 col 1: Prefer using /// for doc comments.
line 31 col 1: Prefer using /// for doc comments.
line 48 col 1: Prefer using /// for doc comments.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
potrace.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.1.0 <3.0.0|