polymer-1.0based apps - support lib
This package is used by autonotify_observe to implement observability on polymer-1.0 apps.
You should not depend on this package directly but instead include
autonotify_observe in your dependencies. See here for more info
More robust notify: will not break your app if something goes wrong while notifying a property (i.e. there's some problem with side effects caused by the propery change).
Updated to support
polymer-1.0.0-rc.10. Just check out this.
Fixes for lists with native types.
Experimental introducing support for
PolymerElement used as an
polymer 1.0.0-rc.8. Changed reference to
observe git repo in deps to be more compliant to de facto convetion for bare repos reference.
demo project to see how to specify deps (BTW until
polymer_elements get upgraded too you need to specify a dependency override for reflectable).
Add this to your package's pubspec.yaml file:
dependencies: polymer_autonotify: ^1.0.0+3
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.0+3||Jul 18, 2016|
|1.0.0+2||Jun 13, 2016|
|1.0.0+1||May 3, 2016|
|1.0.0||Jan 10, 2016|
|0.9.9+99||Jan 9, 2016|
|0.0.2||Sep 21, 2015|
|0.0.1||Sep 18, 2015|
|1.0.0-rc.10+2||Jan 9, 2016|
|1.0.0-rc.10+1||Jan 9, 2016|
|1.0.0-rc.10||Dec 21, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.8.0 <2.0.0|