polymer_app_layout 0.0.6

  • README.md
  • Installing
  • Versions
  • 0

polymer-app-layout - DEPRECATED #

Pub Travis

NB The app-layout elements have now been directly incorporated into the polymer_elements 1.0.0-rc.9 package. This project is now deprecated.

Dart polymer wrappers for app-layout Polymer elements.

Demos #

View demos at polyer-app-layout-demos

Testing #

The original app-layout tests are in the process of being ported. The ported tests can be run as normal dart tests. For example, to run on dartium (default): pub run test As usual, tests can be run on other platforms with -p<platform>

To run tests as javascript, the pub serve and test execution must be performed separately. Run pub serve test --port=8080 from one terminal and pub run test -pchrome --pub-serve=8080 from a second.

Note that tests are specifically blocked from running on Firefox currently in order to utilize Travis CI.

Rebuilding #

Although not necessary for normal use, this package can be rebuilt from the original polymer source using the procedure below. The specific version used as a basis can be specified in bower.json.

  1. Fetch the polymer element source
bower install
  1. Build the Dart wrapper API
pub run custom_element_apigen:update app_layout_dart.yaml

For more information on using custom_element_apigen, see https://pub.dartlang.org/packages/custom_element_apigen

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  polymer_app_layout: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:polymer_app_layout/app_box.dart';
import 'package:polymer_app_layout/app_drawer.dart';
import 'package:polymer_app_layout/app_drawer_layout.dart';
import 'package:polymer_app_layout/app_header.dart';
import 'package:polymer_app_layout/app_header_layout.dart';
import 'package:polymer_app_layout/app_scroll_effects.dart';
import 'package:polymer_app_layout/app_scroll_effects_behavior.dart';
import 'package:polymer_app_layout/app_scrollpos_control.dart';
import 'package:polymer_app_layout/app_toolbar.dart';
import 'package:polymer_app_layout/helpers.dart';
import 'package:polymer_app_layout/iron_flex_layout.dart';
import 'package:polymer_app_layout/iron_media_query.dart';
import 'package:polymer_app_layout/iron_resizable_behavior.dart';
import 'package:polymer_app_layout/iron_scroll_target_behavior.dart';
  
Version Uploaded Documentation Archive
0.0.6 Jul 14, 2016 Go to the documentation of polymer_app_layout 0.0.6 Download polymer_app_layout 0.0.6 archive
0.0.5 Jun 7, 2016 Go to the documentation of polymer_app_layout 0.0.5 Download polymer_app_layout 0.0.5 archive
0.0.4 May 19, 2016 Go to the documentation of polymer_app_layout 0.0.4 Download polymer_app_layout 0.0.4 archive
0.0.3 May 9, 2016 Go to the documentation of polymer_app_layout 0.0.3 Download polymer_app_layout 0.0.3 archive
0.0.2 May 2, 2016 Go to the documentation of polymer_app_layout 0.0.2 Download polymer_app_layout 0.0.2 archive
0.0.1 Apr 28, 2016 Go to the documentation of polymer_app_layout 0.0.1 Download polymer_app_layout 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0