polyglot 1.0.0-dev+1

  • README.md
  • Installing
  • Versions
  • 0

ng2_polyglot #

i18n DSL and compiler for Angular2 Dart.

Example #

@languages [en, es];
"hello" {
    en: "Hello, world!",
    es: "¡Hola, mundo!"


import 'package:angular2/core.dart' show Pipe, PipeTransform;

@Pipe(name: 'polyglot')
class PolyglotPipe implements PipeTransform {
  String transform(String key, [String locale]) {
    if (key == 'hello') {
      if (locale == null) {
        return 'en';
      if (locale == 'en') {
        return 'Hello, world!';
      if (locale == 'es') {
        return '¡Hola, mundo!';
    return 'Unrecognized key: "$key"';

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate polyglot

2. Use it

The package has the following executables:

$ polyglot

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  polyglot: ^1.0.0-dev+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:polyglot/polyglot.dart';
Version Uploaded Documentation Archive
1.0.0-dev+1 Dec 19, 2016 Go to the documentation of polyglot 1.0.0-dev+1 Download polyglot 1.0.0-dev+1 archive
1.0.0-dev Dec 19, 2016 Go to the documentation of polyglot 1.0.0-dev Download polyglot 1.0.0-dev archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0