If you're using PokemonGo-Bot
to level multiple accounts, you might have noticed that the
changes quite often the structure of the configuration files.
Now I've made this to update my files easily when the structure changed.
You need to have an account json file like this one:
Put it in
/path/to/PokemonGo-Bot/configs. You can then fill it with each bot's information.
The "Global" section will be applied to all configurations.
NOTE: The currently supported keys are strictly in the provided JSON above. More keys will come.
You need to have Google Dart installed.
pub global activate pogogen
PokemonGo-Botdirectory, you'll need to type:
configs/config.json.pokemon.exampleas its template.
You can install the package from the command line:
$ pub global activate pogogen
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: pogogen: ^0.4.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.4.2||Aug 2, 2016|
|0.4.1||Aug 2, 2016|
|0.4.0||Aug 2, 2016|
|0.3.1+1||Aug 2, 2016|
|0.3.0||Aug 2, 2016|
|0.2.3||Aug 1, 2016|
|0.2.2||Jul 31, 2016|
|0.2.0||Jul 31, 2016|
|0.1.5||Jul 31, 2016|
|0.1.4||Jul 31, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.