A new Flutter plugin.
For help getting started with Flutter, view our online documentation.
For help on editing plugin code, view the documentation.
Add this to your package's pubspec.yaml file:
dependencies: plugin_social: ^0.0.4
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.8||Jul 2, 2018|
|0.0.7||Jul 2, 2018|
|0.0.6||Jul 2, 2018|
|0.0.5||Jul 1, 2018|
|0.0.4||Jul 1, 2018|
|0.0.3||Jul 1, 2018|
|0.0.2||Jul 1, 2018|
|0.0.1||Jul 1, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Document public APIs. (-1 points)
6 out of 6 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
plugin_social.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.