plugin_android_apk 0.0.1

  • Example
  • Installing
  • Versions
  • 0

plugin_android_apk #

A Flutter plugin for installing android apk.

Getting Started #

add in pubspec.yaml

import 'package:plugin_android_apk/plugin_android_apk.dart';

AndroidApkPlugin.installApk(toFile.path, authority: 'xx.xx.FileProvider');

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.


import 'package:flutter/material.dart';
import 'package:plugin_android_apk/plugin_android_apk.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
    _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {

    initState() {

    Widget build(BuildContext context) {
        return new MaterialApp(
            home: new Scaffold(
                appBar: new AppBar(
                    title: new Text('Android apk example'),
                floatingActionButton: new FloatingActionButton(onPressed: () {

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  plugin_android_apk: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:plugin_android_apk/plugin_android_apk.dart';
Version Uploaded Documentation Archive
0.0.1 Jun 18, 2018 Go to the documentation of plugin_android_apk 0.0.1 Download plugin_android_apk 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0