platform_action_sheet 0.0.2

Platform action sheet #

This package is a simple platform specific actionSheet for Cupertino and Android with the following options:

  • Text - (Required) String to display
  • onPressed - (Required) Function to be executed on the option item being pressed
  • hasArrow - Not visible on IOS, indicating more options will appear
  • isCancel
  • defaultAction

Getting started #

In the pubspec.yaml of your flutter project, add the following dependency:

dependencies:
  ...
  platform_action_sheet: ^0.0.2

In your library add the following import:

import 'package:platform_action_sheet/platform_action_sheet.dart';

For help getting started with Flutter, view the online documentation.

Example #

import 'package:flutter/material.dart';
import 'package:platform_action_sheet/platform_action_sheet.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Example App',
      home: new Home(),
    );
  }
}

class Home extends StatelessWidget {
  const Home({
    Key key,
  }) : super(key: key);

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Example App'),
      ),
      body: Center(
        child: FlatButton(
          color: Colors.blue,
          onPressed: () => PlatformActionSheet().displaySheet(
          context, 
          [
            ActionSheetAction(
              text: "Option 1",
              onPressed: () => Navigator.pop(context),
              hasArrow: true,
            ),
            ActionSheetAction(
              text: "Option 2",
              onPressed: () => Navigator.pop(context),
            ),
            ActionSheetAction(
              text: "Cancel",
              onPressed: () => Navigator.pop(context),
              isCancel: true,
              defaultAction: true,
            )
          ]),
          child: Text(
            'Display ActionSheet',
            textScaleFactor: 1.2,
            style: TextStyle(color: Colors.white),
          ),
        ),
      ),
    );
  }
}

0.0.2 #

  • Only onCancel action causes a divider on the last item
  • Fixed links to demo screenshots

0.0.1 #

  • Initial release.
  • Adds CHANGELOG details.
  • Adds demo screenshots.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  platform_action_sheet: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:platform_action_sheet/platform_action_sheet.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
55
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Feb 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/platform_action_sheet.dart.

Run flutter format to format lib/platform_action_sheet.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and platform_action_sheet.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test