platform 2.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 48

Platform #

Build Status - Coverage Status - Pub

A generic platform abstraction for Dart.

Like dart:io, package:platform supplies a rich, Dart-idiomatic API for accessing platform-specific information.

package:platform provides a lightweight wrapper around the static Platform properties that exist in dart:io. However, it uses instance properties rather than static properties, making it possible to mock out in tests.

2.1.0 #

  • Added localeName
  • Bumped minimum Dart SDK version to 1.24.0-dev.0.0

2.0.0 #

  • Added stdinSupportsAnsi and stdinSupportsAnsi
  • Removed ansiSupported

1.1.1 #

  • Updated LocalPlatform to use new dart.io API for ansi color support queries
  • Bumped minimum Dart SDK version to 1.23.0-dev.10.0

1.1.0 #

  • Added ansiSupported
  • Bumped minimum Dart SDK version to 1.23.0-dev.9.0

1.0.2 #

  • Minor doc updates

1.0.1 #

  • Added const constructors for Platform and LocalPlatform

1.0.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  platform: ^2.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:platform/platform.dart';
  
Version Uploaded Documentation Archive
2.2.0 Aug 13, 2018 Go to the documentation of platform 2.2.0 Download platform 2.2.0 archive
2.1.2 Feb 12, 2018 Go to the documentation of platform 2.1.2 Download platform 2.1.2 archive
2.1.1 Jul 13, 2017 Go to the documentation of platform 2.1.1 Download platform 2.1.1 archive
2.1.0 May 19, 2017 Go to the documentation of platform 2.1.0 Download platform 2.1.0 archive
2.0.0 Apr 5, 2017 Go to the documentation of platform 2.0.0 Download platform 2.0.0 archive
1.1.1 Mar 28, 2017 Go to the documentation of platform 1.1.1 Download platform 1.1.1 archive
1.1.0 Mar 16, 2017 Go to the documentation of platform 1.1.0 Download platform 1.1.0 archive
1.0.2 Feb 13, 2017 Go to the documentation of platform 1.0.2 Download platform 1.0.2 archive
1.0.1 Jan 25, 2017 Go to the documentation of platform 1.0.1 Download platform 1.0.1 archive
1.0.0 Jan 25, 2017 Go to the documentation of platform 1.0.0 Download platform 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
96
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0-dev.0.0 <2.0.0