plain_optional 1.0.0 copy "plain_optional: ^1.0.0" to clipboard
plain_optional: ^1.0.0 copied to clipboard

An implementation of a type `Optional<T>` in Dart, similar to the standard one in Swift.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add plain_optional

With Flutter:

 $ flutter pub add plain_optional

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  plain_optional: ^1.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:plain_optional/plain_optional.dart';
5
likes
140
pub points
74%
popularity

Publisher

unverified uploader

An implementation of a type `Optional<T>` in Dart, similar to the standard one in Swift.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on plain_optional