pk_prompter 0.0.1

This is CLI based lib which will help to ask question's.


import 'package:pk_prompter/pk_prompter.dart';

void main(List<String> args) {
  final prompter = Prompter();

  final String question1 = 'Which color do you want?';
  final options1 = [
    Option('I want red', '#F00'),
    Option('I want blue', '#00F'),
    Option('I want green', '#0F0'),

  final String question2 = 'Do you like this lib?';

  String colorCode = prompter.askMultipleChoice(question1, options1);
  bool answer = prompter.askBinary(question2);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  pk_prompter: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:pk_prompter/pk_prompter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK <5.0.0