pit_payment 0.3.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

Payment Interface by PIT #

Our custom Payment Interface

Note: This plugin is still under development, and some Components might not be available yet or still has so many bugs.

  • This Interface is supported by one of Indonesia's Payment Gateway vendor [Midtrans](midtrans github)

Installation #

First, add pit_payment as a dependency in your pubspec.yaml file.

pit_payment: ^0.3.0

Example #

class PitPaymentDemo extends StatefulWidget {
  @override
  _PitPaymentDemoState createState() => _PitPaymentDemoState();
}

class _PitPaymentDemoState extends State<PitPaymentDemo> {
  @override
  Widget build(BuildContext context) {
    InkWell();
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Pit Payment Demo'),
        ),
        body: SingleChildScrollView(
          child: PitPayment(100000.0, (type, {result}) {
            print("I got payment : $type, $result");
          }),
        ),
      ),
    );
  }
}

0.0.1 #

  • Initial Release

0.0.2 #

  • Dependency fixes

0.0.3 #

  • Dependency fixes

0.0.4 #

  • iOS Dependency fixes

0.0.5 #

  • iOS Dependency fixes

0.0.6 #

  • Dependency fixes

0.0.7 #

  • Bug on Mandiri Click Pay fixed

0.0.8 #

  • Bug fixes

0.0.9 #

  • Android bugs fixed

0.1.0 #

  • Bank Transfer now added

0.1.1 #

  • Dependencies to Stable channel Flutter

0.2.0 #

  • Migrate to AndroidX

0.2.0+1 #

  • Migrate to AndroidX

0.3.0 #

  • I have shut down this plugin for now, please move to this plugin to connect to Midtrans Payment MidFlutter

example/README.md

import 'package:flutter/material.dart';
import 'package:pit_payment/pit_payment.dart';

void main() => runApp(PitPaymentDemo());

class PitPaymentDemo extends StatefulWidget {
  @override
  _PitPaymentDemoState createState() => _PitPaymentDemoState();
}

class _PitPaymentDemoState extends State<PitPaymentDemo> {
  @override
  Widget build(BuildContext context) {
    InkWell();
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Pit Payment Demo'),
        ),
        body: SingleChildScrollView(
          child: PitPayment(100000.0, (type, {result}) {
            print("I got payment : $type, $result");
          }),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pit_payment: ^0.3.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pit_payment/pit_payment.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.42 points)

50 out of 51 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/localization.dart.

Run flutter format to format lib/localization.dart.

Format lib/pit_payment.dart.

Run flutter format to format lib/pit_payment.dart.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (intl, pit_components).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
intl ^0.15.7 0.15.8 0.16.0
pit_components ^0.2.6+2 0.2.11+2 0.5.0+1
Transitive dependencies
after_layout 1.0.7+2
collection 1.14.11 1.14.12
flutter_range_slider 1.4.0
meta 1.1.7 1.1.8
path 1.6.4
photo_view 0.2.5 0.8.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8