pin_code_view 0.2.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

pin_code_view #

A beautiful looking pin_code_view for flutter apps, customizable and fluid. Pull requests are always welcomed.

Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

  pin_code_view: 0.2.1

Usage #

import 'package:pin_code_view/pin_code_view.dart';

class MyWidget extends StatelessWidget {
  Widget build(BuildContext context) {
    return PinCode(
      title: Text(
        "Lock Screen",
        style: TextStyle(
            color: Colors.white, fontSize: 25.0, fontWeight: FontWeight.bold),
      ),
      
      subTitle: Text(
        "Enter the pin code",
        style: TextStyle(color: Colors.white),
      ),
      codeLength: 6,
      // you may skip correctPin and plugin will give you pin as
      // call back of [onCodeFail] before it clears pin
      correctPin: "1234",
      onCodeSuccess: (code) {
        print(code); 
      },
      onCodeFail: (code) {
        print(code); 
      }, 
    );
  }
}

[0.2.1] - 11 Mar 19 #

  • BREAKING CHANGE !!: (onCodeEntered) removed, replaced with onCodeFail/onCodeSuccess with correctPin, if you want the old behaviour just don't provide correctPin and onCodeFail will work the same as the old onCodeEntered
  • new : onCodeSuccess is the callback if entered code matches (==) the correctPin
  • new : onCodeFail is the callback if entered code doesn't matche (!=) the correctPin

[0.1.0] - 2018 Oct 31. #

  • Added obscurePin parameter to make code * instead of number.

[0.0.3] - 2018 Oct 3. #

  • Removed send again button, and added some more customization features.

[0.0.2] - 2018 Oct 3. #

  • Minor bug fixes

[0.0.1] - 2018 Oct 3. #

  • Added very first logics to the code.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:pin_code_view/pin_code_view.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: PinCode(
        title: Text(
          "Lock Screen",
          style: TextStyle(
              color: Colors.white, fontSize: 25.0, fontWeight: FontWeight.bold),
        ),
        subTitle: Text(
          "Hello Boys",
          style: TextStyle(color: Colors.white),
        ),
        obscurePin: true, // to make pin * instead of number
        codeLength: 6,
        onCodeEntered: (code) {
          //callback after full code has been entered
          print(code);
        },
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pin_code_view: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pin_code_view/pin_code_view.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
77
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
69
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • pin_code_view that is a package requiring null.

Maintenance suggestions

Package is getting outdated. (-31.23 points)

The package was last published 68 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test