persistent_data 0.1.3

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  persistent_data: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:persistent_data/persistent_data.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
86
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because of the import of dart:html via the import chain package:persistent_data/persistent_data.dartpackage:persistent_data/src/persistent_data_base.dartdart:html

Package not compatible with runtime flutter-native on ios

Because of the import of dart:html via the import chain package:persistent_data/persistent_data.dartpackage:persistent_data/src/persistent_data_base.dartdart:html

Package not compatible with runtime flutter-native on linux

Because of the import of dart:html via the import chain package:persistent_data/persistent_data.dartpackage:persistent_data/src/persistent_data_base.dartdart:html

Package not compatible with runtime flutter-native on macos

Because of the import of dart:html via the import chain package:persistent_data/persistent_data.dartpackage:persistent_data/src/persistent_data_base.dartdart:html

Package not compatible with runtime flutter-native on windows

Because of the import of dart:html via the import chain package:persistent_data/persistent_data.dartpackage:persistent_data/src/persistent_data_base.dartdart:html

Package not compatible with runtime native-aot

Because of the import of dart:html via the import chain package:persistent_data/persistent_data.dartpackage:persistent_data/src/persistent_data_base.dartdart:html

Package not compatible with runtime native-jit

Because of the import of dart:html via the import chain package:persistent_data/persistent_data.dartpackage:persistent_data/src/persistent_data_base.dartdart:html

Health suggestions

Fix lib/src/persistent_data_base.dart. (-13.96 points)

Analysis of lib/src/persistent_data_base.dart reported 30 hints, including:

line 11 col 7: DO use curly braces for all flow control structures.

line 11 col 13: Unnecessary new keyword.

line 13 col 7: DO use curly braces for all flow control structures.

line 13 col 13: Unnecessary new keyword.

line 25 col 7: DO use curly braces for all flow control structures.

Format lib/persistent_data.dart.

Run dartfmt to format lib/persistent_data.dart.

Maintenance issues and suggestions

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://www.github.com/afpatmin/persistent_data was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

Package is getting outdated. (-84.11 points)

The package was last published 96 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and persistent_data.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
intl ^0.15.7 0.15.8 0.16.1
Transitive dependencies
path 1.7.0