persian_utils 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 69

persian_utils #

Dart CI

persian_utils کتابخانه‌ای است متشکل از متدهای الحاقی کمکی جهت کار با فرهنگ فارسی، در برنامه‌های مبتنی بر Dart و Flutter. این کتابخانه ترجمه‌ای از کتابخانه DNTPersianUtils.Core به زبان Dart می‌باشد.

لیست متدها و امکانات این کتابخانه #

اعتبارسنج‌ها #

نام متد/امکاناتمثالخروجی نمونه
بررسی اعتبار کد ملی"0010350829".isValidIranianNationalCode()true
بررسی اعتبار کد بانکی شبا"IR820540102680020817909002".
isValidIranShebaNumber()
true
بررسی اعتبار کد بانکی شتاب"6221061106498670".
isValidIranShetabNumber()
true
بررسی اعتبار شماره موبایل"09901464762".
isValidIranianMobileNumber()
true
بررسی اعتبار شماره تلفن"37236445".
isValidIranianPhoneNumber()
true
بررسی اعتبار کد پستی"1619735744".
isValidIranianPostalCode()
true
بررسی اعتبار اعداد تمام فارسی"۹۹۹۹۹".
containsOnlyPersianNumbers()
true
بررسی اعتبار حروف و يا اعداد فارسی بودن تنها قسمتی از متن"Abc تست".
containsFarsi()
true
بررسی اعتبار حروف فارسی بودن تمام متن"تست".
containsOnlyFarsiLetters()
true
بررسی اعتبار شناسه ملی حقوقی"14005893875".isValidIranianNationalLegalCode()true

قدردانی #

تشکر از آقای وحید نصیری بابت کتابخانه کامل و مفید DNTPersianUtils.Core

1.0.0 #

  • Added Validation extension methods.

1.0.1 #

  • Removes compiler hints.
  • Added examples

1.0.2 #

  • Removed compiler hints.

example/example.dart

import '../lib/persian_utils.dart';

main() {
  // --------- Validators example ---------

  assert('0077611616'.isValidIranianNationalCode());
  assert('1619735744'.isValidIranianPostalCode());

  assert('37236445'.isValidIranianPhoneNumber());

  assert('+989355214655'.isValidIranianMobileNumber());
  assert('989355214655'.isValidIranianMobileNumber());
  assert('00989355214655'.isValidIranianMobileNumber());
  assert('09355214655'.isValidIranianMobileNumber());
  assert('09901464762'.isValidIranianMobileNumber());
  assert('9901464762'.isValidIranianMobileNumber());

  assert('IR820540102680020817909002'.isValidIranShebaNumber());
  assert('IR062960000000100324200001'.isValidIranShebaNumber());

  assert('6221061106498670'.isValidIranShetabNumber());
  assert('636214-1075165358'.isValidIranShetabNumber());

  assert('00103508290'.isValidIranianNationalLegalCode());
  assert('10101780644'.isValidIranianNationalLegalCode());

  assert('0010350829'.isNumber());

  assert(''.isNullOrEmpty());

  assert(' '.isNullOrWhiteSpace());

  // ----------- RegExp Utils example -----------
  assert('Abc تست'.containsFarsi());

  assert('۱۲۳'.containsOnlyPersianNumbers());

  assert('چحخدذرز'.containsOnlyFarsiLetters());

  assert('دوست​ها'.containsThinSpace()); // 8203    \u200B
  assert('دوست‌ها'.containsThinSpace()); // 8204    \u200C
  assert('دوست‎ها'.containsThinSpace()); // 8206    \u200E
  assert('دوست‏ها'.containsThinSpace()); // 8207    \u200F

  // ---------- Converter example ----------
  assert('123'.toPersianNumbers() == '۱۲۳');

  assert('۰۱۲۳۴۵۶۷۸۹'.toEnglishNumbers() == '0123456789');

  assert('يكي'.applyCorrectYeKe() == 'یکی');

  // ------------ Finish -------------
  print('All done.');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  persian_utils: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:persian_utils/persian_utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
37
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
Dev dependencies
test >=0.12.42 <2.0.0