perfectionist 2.0.0

perfectionist #

Enabled Lints #

The currently enabled lints can be found in the sample analysis_options.yaml.

To use those lints you can add a dependency in your pubspec.yaml:

# If you also need to import `package:perfectionist/perfectionist.dart`, it's a
# normal dependency.
dependencies:
  perfectionist: '^2.0.0'

# Or, if you just want `analysis_options.yaml`, it can be a dev dependency.
dev_dependencies:
  perfectionist: '^2.0.0'

and add an include in your analysis_options.yaml:

include: package:perfectionist/analysis_options.yaml

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  perfectionist: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Jan 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.1-dev.0.0 <3.0.0