pdrpulm 1.0.2
pdrpulm: ^1.0.2

discontinued Dart 2 incompatible

Idiom for Pull-Down-Refresh & Pull-Up-Load-More for ListView

pdrpulm (Pull Down to Refresh & Pull Up to Load More) #

A widget that supports "Pull Down to Refresh & Pull Up to Load More" idiom. Google Material never have "Pull Up to Load More" so implement as a package.

Getting Started #

Widget build(BuildContext context) {
    return new ScrollIndicator(
        onLoadMore: onLoadMore,
        child: new ListView.builder(
            itemCount: itemCount,
            itemBuilder: (BuildContext context, int index) {
              return new Container(
                height: 150.0,
                decoration: new BoxDecoration(border: new Border.all()),
                child: new Indicator(index.toString()),
              );
            }));
  }

Roadmap #

add custom indicator when refresh or loading more

0
likes
0
pub points
0%
popularity

Idiom for Pull-Down-Refresh & Pull-Up-Load-More for ListView

Repository
View/report issues

Uploader

ken.shao@gmail.com

Dependencies

flutter

More

Packages that depend on pdrpulm