Flutter Pdfium #
This project aims to wrap the complete Pdfium API in dart, over FFI.
It's currently only a proof-of-concept, but can successfully produce bitmaps from PDF files.
This has the potential to build a truly cross platform, high-level API for rendering and editing PDFs on all 5 platforms.
- [ ] Build Pdfium shared libraries for all platforms. (pdfium_builder)
- [ ] Find a way to generate FFI code from C headers.
- [ ] Integrate into flutter_pdf_viewer.
A big THANK YOU to Google for open sourcing Pdfium, and releasing dart:ffi.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: pdfium: ^0.0.1
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jun 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.8.2
- pana: 0.13.8-dev
Maintenance issues and suggestions
Provide a file named
CHANGELOG.md. (-20 points)
Changelog entries help developers follow the progress of your package. See the example generated by
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
The package description is too short. (-16 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
pdfium.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.6.0-dev.8.2 <3.0.0|