A pubspec maintenance tool.
pub global activate pbsm
pbsm init # inialize pubspec.yaml in current directory pbsm init target # inialize pubspec.yaml in target directory pbsm init -y # inialize pubspec.yaml without prompt
Install package and update pubspec.yaml.
pbsm install test # install test package from pub.dartlang.org pbsm install --git git://github.com/dart-lang/test.git test # install package from git url
Uninstall package and update pubspec.yaml.
pbsm uninstall test
You can install the package from the command line:
$ pub global activate pbsm
The package has the following executables:
|0.1.6||Mar 4, 2017|
|0.1.5||Feb 1, 2017|
|0.1.4||Jan 20, 2017|
|0.1.2||Jan 14, 2017|
|0.1.1||Jan 14, 2017|
|0.1.0||Jan 14, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.8.0 <2.0.0|