payjp_flutter 0.1.5

Flutter Plugin for PAY.JP SDK #

pub package Build Status

A Flutter plugin for PAY.JP Mobile SDK.

オンライン決済サービス「PAY.JP」をFlutterアプリケーションに組み込むためのプラグインです。 このプラグインは以下の機能を提供します。

  • クレジットカード決済のためのカードフォーム
  • Apple Payアプリ内決済(iOSのみ)


Compatible Platforms #


License #

Flutter Plugin for PAY.JP SDK is available under the MIT license. See the LICENSE file for more info.

Development #

Generate models #

See generator/

Bump up version #


0.1.5 #

  • Fix error message deserialization problem on Apple Pay (iOS).

0.1.4 #

  • Update payjp-ios to 1.1.5.
  • Update payjp-android to 1.1.3.

0.1.3 #

  • Update payjp-ios to 1.1.3.

0.1.2 #

  • Update payjp-ios to 1.1.2.

0.1.1 #

  • Support Flutter Android embedding version 2 (and still support v1 too).

0.1.0 #

  • Update payjp-android to 1.1.2.

0.0.1 #

Initial release.


payjp_flutter_example #

Demonstrates how to use the payjp_flutter plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  payjp_flutter: ^0.1.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:payjp_flutter/payjp_flutter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/src/serializers.g.dart.

Run flutter format to format lib/src/serializers.g.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
built_value >=7.0.4 <8.0.0 7.0.9
flutter 0.0.0
meta >=1.1.8 <2.0.0 1.1.8
Transitive dependencies
built_collection 4.3.2
collection 1.14.11 1.14.12
fixnum 0.10.11
matcher 0.12.6
path 1.6.4
quiver 2.1.2+1
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner any
built_value_generator any