path 1.7.0
path: ^1.7.0
path: ^1.8.0-nullsafety.3

Dart native js
Flutter Android iOS web

A string-based path manipulation library. All of the path operations you know and love, with solid support for Windows, POSIX (Linux and Mac OS X), and the web.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  path: ^1.7.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:path/path.dart';
264
likes
110
pub points
100%
popularity

Publisher

dart.dev

A string-based path manipulation library. All of the path operations you know and love, with solid support for Windows, POSIX (Linux and Mac OS X), and the web.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

More

Packages that depend on path