password_dumb 0.0.2 icon indicating copy to clipboard operation
password_dumb: ^0.0.2 copied to clipboard

Guard your users against entering dumb passwords in your flutter app.

Password Dumb #

A simple (but correct) Dart class to check if password is dumb, also can be use to generate strong password.

Installation #

This package requires the latest version of Dart. You can download the latest and greatest here.

1. Depend on it #

Add this to your package's pubspec.yaml file:

dependencies:
    password_dumb: '^0.0.1'

2. Install it

You can install packages from the command line:

$ pub get
..

Alternatively, your editor might support pub. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:password_dumb/password_dumb.dart';

Usage #

Read the unit tests under test, or see code example below:

void main() {

    var password = "12345678";

    assert(PasswordDumb.validate(password));
}

Tips #

You can also use this repo as a template for creating Dart packages, just clone the repo and start hacking :)

3
likes
120
pub points
0%
popularity

Publisher

unverified uploader

Guard your users against entering dumb passwords in your flutter app.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on password_dumb