password_criteria 0.1.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 57

password_criteria #

Getting Started #

A new Flutter plugin for password criteria #

Current version (0.1.4) Bug Fixes and clean code

This package returns a container view which is having 5 criteria in Red color.

#criteria

  1. At least one lower case
  2. At least on upper case
  3. At least One number
  4. one special character
  5. Minimum 8 character

When one starts typing & the password starts meeting the criterion specified, the corresponding/respective criterion turns black in color. It ie a very useful library for signup forms & change password forms

0.1.2 #

  • BUg fixes and clean code

example/lib/main.dart

import 'package:flutter/cupertino.dart';
import 'package:flutter/material.dart';
import 'package:password_criteria/password_criteria.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(

        primarySwatch: Colors.blue,
      ),
      home: PasswordCriteria(title: 'Flutter Demo Home Page'),
    );
  }
}

class PasswordCriteria extends StatefulWidget {
  @override
  PasswordCriteriaPageState createState() => PasswordCriteriaPageState();

  PasswordCriteria({Key key, this.title}) : super(key: key);
  final String title;
}

class PasswordCriteriaPageState extends State<PasswordCriteria> {
  String password ="";

  @override
  Widget build(BuildContext context) {
    // TODO: implement build
    return Scaffold(
      appBar: AppBar(
        title: Text("Password Crtiteria"),
      ),
      body: Center(
        child: Column(
          children: <Widget>[
            Container(
              child: TextField(
                onChanged: (value) {
                  setState(() {
                    password = value;
                  });
                   //PasswordStrengthPage(value);
                },
              ),
            ),
            Container(
              child: PasswordStrengthPage(password),
            )
          ],
        ),
      ),
      // This trailing comma makes auto-formatting nicer for build methods.
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  password_criteria: ^0.1.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:password_criteria/password_criteria.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
23
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:password_criteria/password_criteria.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:password_criteria/password_criteria.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:password_criteria/password_criteria.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:password_criteria/password_criteria.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • password_criteria that is a package requiring null.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (bloc, flutter_bloc).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
bloc ^4.0.0 4.0.0 5.0.1
equatable ^1.1.1 1.2.0
flutter 0.0.0
flutter_bloc ^4.0.0 4.0.1 5.0.1
meta ^1.1.8 1.1.8 1.2.2
Transitive dependencies
collection 1.14.12 1.14.13
nested 0.0.4
provider 4.3.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test