password_compromised 1.0.0

password-compromised #

License Build

Introduction #

password-compromised is a dart package inspired by password-leak that can be used to determine if a password is compromised by checking with the Have I Been Pwned API.

How is this safe? #

Your passwords are NEVER transmitted to any other system. This library makes use of the Have I Been Pwned API, which implements a k-Anonymity Model so your password can be checked without ever having to give it to any other party.

Usage #

import 'package:password_compromised/password_compromised.dart';

main() async {
  final isCompromised = await isPasswordCompromised('test');
  print('Password "test" is compromised? ${isCompromised}');
}

1.0.0 #

  • Initial version

example/password_compromised_example.dart

import 'package:password_compromised/password_compromised.dart';

main() async {
  final isCompromised = await isPasswordCompromised('test');
  print('Password "test" is compromised? ${isCompromised}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  password_compromised: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:password_compromised/password_compromised.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:password_compromised/password_compromised.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.1 <3.0.0
crypto ^2.0.6 2.0.6
http ^0.12.0+2 0.12.0+2
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
http_parser 3.1.3
meta 1.1.7
path 1.6.2
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
pedantic ^1.7.0 1.8.0+1
random_string ^1.1.0
test ^1.6.0

Admin