parse_sdk_dart 0.0.4

Parse SDK for Dart/Flutter #

  • Similar projects:

https://github.com/lotux/parse_server_dartt

  • Dependencies:

HTTP client: https://github.com/flutterchina/dio

Usage #

A simple usage example:

import 'package:parse_sdk_dart/parse_sdk_dart.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.0 #

  • Initial version, created by Stagehand

example/parse_sdk_dart_example.dart

import 'package:parse_sdk_dart/parse_sdk_dart.dart';

main() {
  var awesome = new Awesome();
  print('awesome: ${awesome.isAwesome}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  parse_sdk_dart: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:parse_sdk_dart/parse_sdk_dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

We analyzed this package on Sep 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:parse_sdk_dart/parse_sdk_dart.dart with components: io.

Health suggestions

Format lib/src/http/http_options.dart.

Run dartfmt to format lib/src/http/http_options.dart.

Format lib/src/parse/parse_constants.dart.

Run dartfmt to format lib/src/parse/parse_constants.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/nextfunc/parse-sdk-dart was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dio).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
dio ^1.0.9 1.0.17 3.0.0
Transitive dependencies
cookie_jar 0.0.8 1.0.1
Dev dependencies
test ^1.0.0