palette_generator 0.3.3+3 copy "palette_generator: ^0.3.3+3" to clipboard
palette_generator: ^0.3.3+3 copied to clipboard

Flutter package for generating palette colors from a source image.

0.3.3+3 #

  • Adds pub topics to package metadata.
  • Updates minimum supported SDK version to Flutter 3.7/Dart 2.19.
  • Aligns Dart and Flutter SDK constraints.

0.3.3+2 #

  • Ignores lint warnings from new changes in Flutter master.
  • Suppresses deprecation warnings for changes to Flutter master.
  • Fixes lint warnings.

0.3.3+1 #

  • Migrates from ui.hash* to Object.hash*.

0.3.3 #

  • Avoids dynamic calls in equality checks.

0.3.2 #

  • Fix typos
  • Fix unnecessary_import lint errors.

0.3.1 #

  • Add PaletteGenerator.fromByteData to allow creating palette from image byte data.

0.3.0 #

  • Migrated to null safety.

0.2.4+1 #

  • Removed a dart:async import that isn't required for >=Dart 2.1.

0.2.4 #

  • Fix PaletteGenerator.fromImageProvider region not scaled to fit image size.

0.2.3 #

  • Bumped minimum Flutter version to 1.15.21 to pick up Diagnosticable as a mixin and remove DiagnosticableMixin.

0.2.2 #

  • Bumped minimum Flutter version to 1.6.7 to pick up DiagnosticableMixin.

0.2.1 #

  • PaletteGenerator: performance improvements.

0.2.0 #

  • Updated code to be compatible with Flutter breaking change.

0.1.1 #

  • Fixed a problem with a listener that wasn't being unregistered properly.

0.1.0 #

  • Initial Open Source release.
578
likes
140
pub points
98%
popularity

Publisher

verified publisherflutter.dev

Flutter package for generating palette colors from a source image.

Repository (GitHub)
View/report issues
Contributing

Topics

#color #ui

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, flutter

More

Packages that depend on palette_generator