paged_cards 1.0.2

  • Readme
  • Changelog
  • Installing
  • 41

PagedCards #

Flutter widget to show a horizontal list of paged cards which can be swiped-through or scrolled up to transition to full width.

Bookstore Demo

[1.0.2] - 2019-07-10 #

  • Wrap all children in GestureDetectors, such that States are reused by Key.

[1.0.1] - 2019-07-10 #

  • Expose FullscreenOverlayRoute.

[1.0.0] - 2019-07-10 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  paged_cards: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:paged_cards/paged_cards.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [paged_cards] that is in a package requiring null.

Health suggestions

Fix lib/src/card.dart. (-0.50 points)

Analysis of lib/src/card.dart reported 1 hint:

line 52 col 21: Avoid using braces in interpolation when not needed.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and paged_cards.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is getting outdated. (-7.40 points)

The package was last published 56 weeks ago.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0-dev.0.5.flutter-a1668566e5 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies