pagarme_mpos_flutter 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new57

pagarme_mpos_flutter #

Plugin para utilização da integração de pagamento via pinpad do Pagarme.

Introdução #

Este projeto é para quem precisa utilizar a integração de pagamento do Pagarme via pinpad em um aplicativo flutter. O papel deste plugin é apenas fornecer a comunicação entre o aplicativo e a lib nativa já disponibilizada pelo Pagarme.

No momento eu desenvolvi apenas a versão Android, que ainda está em testes e poderá sofrer alterações. Como sou novo no flutter/dart eu acredito que também há algumas oportunidades de melhoria no fluxo de comunicação e qualidade de código do plugin. Toda ajuda é bem vinda :)

Pretendo trabalhar na versão iOS e disponibilizar uma versão "beta" até o início de abril/2020.

Configuração #

O funcionamento da integração é bem parecido com o fluxo presente na documentação oficial. Para ver uma implementação do plugin, acesse a pasta example/ deste projeto. O exemplo é bem simples ainda, mas é possível compreender e aproveitá-lo em seu projeto.

Contribuições #

Fique à vontade para submeter alguma issue ou PR, caso encontre um erro ou oportunidade de melhoria.

Dúvidas #

Pode entrar em contato comigo no email: william@williampereira.me

0.1.x #

0.1.0 - Initial release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:pagarme_mpos_flutter/pagarme_mpos_flutter.dart';
import 'package:pagarme_mpos_flutter_example/device.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {

  String _platformVersion = 'Unknown';
  PagarmeMpos mpos = new PagarmeMpos();

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await mpos.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }
    
    // Device initialization
    Device device = new Device(
      deviceName: '...', // Device Name
      amount: 1000,
      paymentMethod: PaymentMethod.CreditCard,
      mpos: mpos
    );

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Mpos Example App'),
        ),
        body: Center(
            child: Padding(
          padding: EdgeInsets.all(20.0),
          child: Column(
            children: <Widget>[
              Text('Running on: $_platformVersion\n'),
              StreamBuilder(
                  stream: mpos.events,
                  builder: (context, snapshot) {
                    if (snapshot.hasData) {
                      return Text('Last mpos event: ${snapshot.data}');
                    }
                    return Text('No data');
                  }),
                  const RaisedButton(
          onPressed: null,
          child: Text(
            'Disabled Button',
            style: TextStyle(fontSize: 20)
          ),
        ),
            ],
          ),
        )),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pagarme_mpos_flutter: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pagarme_mpos_flutter/pagarme_mpos_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

20 out of 20 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/pagarme_mpos_flutter.dart.

Run flutter format to format lib/pagarme_mpos_flutter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test