padder 0.1.0

  • Installing
  • Versions
  • 28

Padder #

Padder is a Flutter package of simple padding widgets.

Sick of typing padding boilerplate like this?

new Padding(padding: new EdgeInsets.only(top: 16.0), child: myWidget);

Then Padder is for you!

Padder contains widgets such as PaddingTop that transform the line above into:

new PaddingTop(16.0, myWidget)

It may not seem like much but when tweaking Flutter layouts all day long, Padder widgets are much easier to use and remember!

Widgets #

  • PaddingAll
  • PaddingTop
  • PaddingLeft
  • PaddingRight
  • PaddingVertical
  • PaddingHorizontal
  • PaddingSymmetrical

Padder also has Sliver variants of all the widgets above

[0.1.0] - 04/05/18

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  padder: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:padder/padder.dart';
Version Uploaded Documentation Archive
1.2.0 Feb 18, 2019 Go to the documentation of padder 1.2.0 Download padder 1.2.0 archive
1.1.0 Nov 13, 2018 Go to the documentation of padder 1.1.0 Download padder 1.1.0 archive
1.0.1 Apr 4, 2018 Go to the documentation of padder 1.0.1 Download padder 1.0.1 archive
1.0.0 Apr 3, 2018 Go to the documentation of padder 1.0.0 Download padder 1.0.0 archive
0.1.0 Apr 3, 2018 Go to the documentation of padder 0.1.0 Download padder 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8


Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.3.0-dev.0.1.flutter-1f1592edce.
 Because padder requires SDK version >=1.2.0 <=2.0.0, version solving failed.

Health suggestions

Format lib/padding.dart.

Run flutter format to format lib/padding.dart.

Format lib/sliver_padding.dart.

Run flutter format to format lib/sliver_padding.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support the latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and padder.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is getting outdated. (-9.59 points)

The package was last published 57 weeks ago.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.2.0 <=2.0.0