package_config_2 2.0.0

package_config #

Support for working with Package Resolution Configuration files as described in this DEP, under review here.

Build Status pub package

Features and bugs #

Please file feature requests and bugs at the issue tracker.

2.0.0 #

  • Based on new JSON file format with more content.

1.2.0 #

  • Added support for writing default-package entries.
  • Fixed bug when writing Uris containing a fragment.

1.1.0 #

  • Allow parsing files with default-package entries and metadata. A default-package entry has an empty key and a valid package name as value. Metadata is attached as fragments to base URIs.

1.0.5 #

  • Fix usage of SDK constants.

1.0.4 #

  • Set max SDK version to <3.0.0.

1.0.3 #

  • Removed unneeded dependency constraint on SDK.

1.0.2 #

  • Update SDK constraint to be 2.0.0 dev friendly.

1.0.1 #

  • Fix test to not write to sink after it's closed.

1.0.0 #

  • Public API marked stable.

0.1.5 #

  • FilePackagesDirectoryPackages.getBase(..) performance improvements.

0.1.4 #

  • Strong mode fixes.

0.1.3 #

  • Invalid test cleanup (to keep up with changes in Uri).

0.1.1 #

  • Syntax updates.

0.1.0 #

  • Initial implementation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  package_config_2: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:package_config_2/package_config.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package is not analyzed, because it is discontinued.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0