p_install 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 63

p_install #

不成熟的 app 更新插件

Getting Started #

Android #

  1. 安装的 apk 文件不在 app 安全目录下时,需要自己获取 sdcard 读写权限

注意: apk 文件存储到应用内部缓存文件夹下会导致包解析错误,建议存储在外部缓存文件夹下: /storage/emulated/0/Android/data/[app package]/cache/

IOS #

打开 App Store

Usage #

PInstall.install(iosUrl: url);

PInstall.install(filePath: androidApkFilePath);

0.0.4 #

  1. fix android FileProvider

0.0.3 #

  1. update readme

0.0.2 #

0.0.1-dev.1 #

  1. update readme

0.0.1 #

不成熟的 app 升级插件

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:p_install/p_install.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
  }
//  https://itunes.apple.com/cn/app/%E5%86%8D%E6%83%A0%E5%90%88%E4%BC%99%E4%BA%BA/id1375433239?l=zh&ls=1&mt=8

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  p_install: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:p_install/p_install.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:p_install/p_install.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:p_install/p_install.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:p_install/p_install.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:p_install/p_install.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • p_install that is a package requiring null.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test