owl_codegen 0.4.0+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 30

Owl source code generator #

Source code generator for JSON serialization, HTTP APIs and SQL CRUD.

Usage #

A simple usage example can be found in the example project.

Warning: pre-1.0 API is subject to change. Please contact the contributors if you need migration path for early versions.

Changelog #

0.4.0+1 #

  • Fix DateTime parser.

0.4.0 #

  • Upgraded to Dart 2 only.
  • Breaking change: package:postgresql is replaced by package:postgres.

0.3.0 #

  • Updated to Dart 2.

0.2.4 #

  • Use lowercase JSON and UTF8 from dart:convert.

0.2.3 #

  • Support annotated getters and setters for JSON generator.
  • Fixed analysis_options.yaml.
  • Upgrade dependencies.
  • Suppress strong-mode warnings in generated code.

0.2.2 #

  • Upgrade dependencies (build, build_runner and source_gen).

0.2.1+2 #

  • Bugfix: exclude final or setter-only fields (e.g. hashCode).

0.2.1+1 #

  • Bugfix in SQL: Table.create's ifNotExists should propagate schema and table.

0.2.1 #

  • Added missing SQL type mapping.
  • Add support for table name overrides (both for CRUD and for DDL).

0.2.0 #

  • Added support for Postgresql schema prefixes (both for CRUD and for DDL).
  • Better support for foreign key names, deterministically generating one if absent (it is a breaking change if you relied on the default behavior previously).
  • DDL supports adding new columns incrementally. (Deleting columns should be the role of the database operator.)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  owl_codegen: ^0.4.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:owl_codegen/ext/id.dart';
import 'package:owl_codegen/config.dart';
import 'package:owl_codegen/http_generator.dart';
import 'package:owl_codegen/json_generator.dart';
import 'package:owl_codegen/sql_generator.dart';
import 'package:owl_codegen/utils.dart';
  
Version Uploaded Documentation Archive
0.4.0+1 Sep 2, 2018 Go to the documentation of owl_codegen 0.4.0+1 Download owl_codegen 0.4.0+1 archive
0.4.0 Sep 1, 2018 Go to the documentation of owl_codegen 0.4.0 Download owl_codegen 0.4.0 archive
0.3.0 Jul 16, 2018 Go to the documentation of owl_codegen 0.3.0 Download owl_codegen 0.3.0 archive
0.2.4 Apr 23, 2018 Go to the documentation of owl_codegen 0.2.4 Download owl_codegen 0.2.4 archive
0.2.3 Feb 13, 2018 Go to the documentation of owl_codegen 0.2.3 Download owl_codegen 0.2.3 archive
0.2.2 Aug 28, 2017 Go to the documentation of owl_codegen 0.2.2 Download owl_codegen 0.2.2 archive
0.2.1+2 Jul 9, 2017 Go to the documentation of owl_codegen 0.2.1+2 Download owl_codegen 0.2.1+2 archive
0.2.1+1 Jul 2, 2017 Go to the documentation of owl_codegen 0.2.1+1 Download owl_codegen 0.2.1+1 archive
0.2.1 Apr 8, 2017 Go to the documentation of owl_codegen 0.2.1 Download owl_codegen 0.2.1 archive
0.2.0 Apr 2, 2017 Go to the documentation of owl_codegen 0.2.0 Download owl_codegen 0.2.0 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Jun 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18

Platforms

Detected platforms: other

Platform components identified in package: build, io, isolate, mirrors.

Health suggestions

Fix lib/ext/id.dart. (-1 points)

Analysis of lib/ext/id.dart reported 2 hints:

line 21 col 14: The top level variable '_logger' isn't used.

line 89 col 9: Use contains instead of indexOf

Fix lib/sql_generator.dart. (-0.50 points)

Analysis of lib/sql_generator.dart reported 1 hint:

line 261 col 62: Use = to separate a named parameter from its default value.

Format lib/http_generator.dart.

Run dartfmt to format lib/http_generator.dart.

Maintenance issues and suggestions

Support latest dependencies. (-90 points)

The version constraint in pubspec.yaml does not support the latest published versions for 13 dependencies (5 direct: analyzer, build, build_runner, quiver, source_gen).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and owl_codegen.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
analyzer ^0.32.3 0.32.6 0.36.3
args ^1.3.0 1.5.2
build ^0.12.0 0.12.7+3 1.1.4
build_runner ^0.9.1 0.9.2 1.6.0
owl ^0.4.0 0.4.0
quiver ^0.29.0 0.29.0+2 2.0.3
source_gen ^0.8.3 0.8.3+1 0.9.4+2
yaml ^2.1.12 2.1.16
Transitive dependencies
async 2.2.0
build_config 0.3.2 0.4.0
build_resolvers 0.2.2+7 1.0.5
build_runner_core 0.2.2+2 3.0.6
built_collection 4.2.2
built_value 6.6.0
charcode 1.1.2
cli_util 0.1.3+2
code_builder 3.2.0
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.16.0
dart2_constant 1.0.2+dart2
dart_style 1.1.3 1.2.8
fixnum 0.10.9
front_end 0.1.4+2 0.1.18
glob 1.1.7
graphs 0.1.3+1 0.2.0
html 0.14.0+2
http_multi_server 2.1.0
http_parser 3.1.3
io 0.3.3
json_annotation 1.2.0 2.4.0
kernel 0.3.4+2 0.3.18
logging 0.11.3+2
matcher 0.12.5
meta 1.1.7
mime 0.9.6+3
package_config 1.0.5
path 1.6.2
plugin 0.2.0+3
pool 1.4.0
postgres 1.0.2
pub_semver 1.4.2
pubspec_parse 0.1.4
shelf 0.7.5
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
stream_transform 0.0.19
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10