ordered_set 4.0.0 copy "ordered_set: ^4.0.0" to clipboard
ordered_set: ^4.0.0 copied to clipboard

outdated

A simple implementation of an Ordered Set for Dart that allows multiple items with the same priority.

4.0.0 #

  • Add Comparing#mapper
  • Add strictMode to QueryableOrderedSet

3.2.0 #

  • Change QueryableOrderedSet.register to be no-op if type is already registered

3.1.0 #

  • Add QueryableOrderedSet

3.0.0 #

  • Add null safety for this package
  • Add methods for rebalancing

2.0.2 #

  • Improve repository organization

2.0.1 #

  • Simplify implementation of iterator and removeWhere

2.0.0 #

  • Change removeWhere api

1.1.5 #

  • Fix coveralls, bump dependencies

1.1.4 #

  • Improve build and fix warnings

1.1.3 #

  • Formatting, removing warnings

1.1.2 #

  • Fix for dart2

1.1.0 #

  • Improving documentation via dartdocs

1.0.0 #

  • Adding Comparing class

0.1.0 #

  • Initial version, adding Ordered Set with basic operations
29
likes
0
pub points
92%
popularity

Publisher

verified publisherblue-fire.xyz

A simple implementation of an Ordered Set for Dart that allows multiple items with the same priority.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

More

Packages that depend on ordered_set