Package to interact with the OpenLibrary API.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: oplibrary: ^0.0.3
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.5
Health issues and suggestions
Document public APIs. (-1 points)
23 out of 23 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
lib/src/models/document_search_result.dart. (-3.93 points)
lib/src/models/document_search_result.dart reported 8 hints, including:
line 15 col 8: Use isEmpty instead of length
line 16 col 42: Unnecessary new keyword.
line 18 col 19: Unnecessary new keyword.
line 20 col 15: Unnecessary new keyword.
line 21 col 21: Unnecessary new keyword.
lib/oplibrary.dart. (-1.99 points)
lib/oplibrary.dart reported 4 hints:
line 15 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 18 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 27 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 33 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
lib/src/models/search_result_model.dart. (-0.50 points)
lib/src/models/search_result_model.dart reported 1 hint:
line 13 col 12: Unnecessary new keyword.
Maintenance issues and suggestions
Provide a file named
CHANGELOG.md. (-20 points)
Changelog entries help developers follow the progress of your package. See the example generated by
The package description is too short. (-15 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
oplibrary.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
Package is getting outdated. (-9.59 points)
The package was last published 57 weeks ago.
|Dart SDK||>=2.0.0-dev.28.0 <3.0.0|