ooga04_speaker 0.0.10

  • Readme
  • Changelog
  • Installing
  • 68

speaker #

Play the specified resource as audio.

Feature #

  • Speaking resources over HTTP(S)
  • Plays audio even when the app is in the background
  • You can define what happens when playback ends (normal or abnormal)
  • There is no way to stop it if it starts in the current version
  • iOS isn't support.

Usage #


  var _speaker = Speaker(onSpeakEnd: () async {
    // Write processing at the speak end.
  });

  await _speaker.play("speaking resource");


  var _speaker = Speaker(onSpeakEnd: () async {
    // Write processing at the all speak end.
  });

  await _speaker.plays(["speaking resource1", "speaking resource2"]);

0.0.1 #

  • play and triggering speak end.

0.0.9 #

  • supported ios

0.0.10 #

  • add plays interface(only android support)
  • ios supported end audio play handler

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ooga04_speaker: ^0.0.10

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ooga04_speaker/generated/i18n.dart';
import 'package:ooga04_speaker/speaker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
51
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Dec 5, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Format lib/speaker.dart.

Run flutter format to format lib/speaker.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ooga04_speaker.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test