ontology_dart_sdk 1.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 48

Dart SDK For Ontology blockchain

This is a Dart SDK for the Ontology blockchain and could be used in the Flutter development.

It supports:

  • Wallet management
  • Digital identity management
  • Digital asset management
  • Smart Contract deployment and invocation
  • Ontology blockchain API

It's recommend to take a quick view of the Ontology Development Guide before your development. The test cases folder contains various examples they are also worth a glance.

Online API reference or view it on filesystem.

Install #

For using this package in your project you'd firstly update your pubspec.yaml file to contains blew lines:

dependencies:
  ontology_dart_sdk: ^1.0.0

and then run the package installation command:

flutter packages get

Run the tests #

Testing in flutter is interesting, our test code and business code run in two separate processes. The test code takes screen captures of the running business code to perform further predicate code. For more details under this mechanism please refer integration testing.

Here are the steps to start the tests:

  1. Downloading the executable binary file of Ontology from it's release page. The version used in the tests is ontology version v1.6.0-8-g754303c0
  2. Copying the test wallet located in file example/lib/test/common/wallet.dart and save it into file wallet.dat then put the saved wallet file and the Ontology binary from step 1 under the same directory.
  3. Starting Ontology node runs in test mode ./ontology --testmode --loglevel=1
  4. Starting the tests: cd example/ && flutter drive --target=test_driver/app.dart

Below is a screenshot from tests:

0.0.1 #

  • TODO: Describe initial release.

example/README.md

ontology_dart_sdk_example #

Demonstrates how to use the ontology_dart_sdk plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ontology_dart_sdk: ^1.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ontology_dart_sdk/common.dart';
import 'package:ontology_dart_sdk/crypto.dart';
import 'package:ontology_dart_sdk/neocore.dart';
import 'package:ontology_dart_sdk/network.dart';
import 'package:ontology_dart_sdk/settings.dart';
import 'package:ontology_dart_sdk/wallet.dart';
  
Version Uploaded Documentation Archive
1.0.3 Mar 14, 2019 Go to the documentation of ontology_dart_sdk 1.0.3 Download ontology_dart_sdk 1.0.3 archive
1.0.2 Mar 1, 2019 Go to the documentation of ontology_dart_sdk 1.0.2 Download ontology_dart_sdk 1.0.2 archive
1.0.1 Mar 1, 2019 Go to the documentation of ontology_dart_sdk 1.0.1 Download ontology_dart_sdk 1.0.1 archive
1.0.0 Mar 1, 2019 Go to the documentation of ontology_dart_sdk 1.0.0 Download ontology_dart_sdk 1.0.0 archive
0.0.1 Mar 1, 2019 Go to the documentation of ontology_dart_sdk 0.0.1 Download ontology_dart_sdk 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jun 26, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.92 points)

753 out of 755 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (1 direct: meta).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0-dev.9.4 <3.0.0
collection ^1.14.11 1.14.11
convert ^2.0.2 2.1.1
flutter 0.0.0
meta ^1.1.6 1.1.6 1.1.7
uuid ^2.0.0 2.0.2
web_socket_channel ^1.0.9 1.0.13
Transitive dependencies
async 2.2.0
charcode 1.1.2
crypto 2.0.6
sky_engine 0.0.99
stream_channel 2.0.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_driver
flutter_test
test any