okhi_flutter_widget 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

OkHi Flutter Widget #

This Widget provides you with a quick and easy way to start collecting high accuracy location information from your users.

Requirements #

  • An OkHi API Key. Get one here

Usage #

To use this plugin, add okhi_flutter_widget as a dependency in your pubspec.yaml file.

Example #

import 'package:flutter/material.dart';
import 'package:okhi_flutter_widget/okhi_flutter_widget.dart';

class MyScreen extends StatelessWidget {
  @override
  Widget build(BuildContext context) {

    // make sure to have an apiKey before hand
    OkHiAuth auth = OkHiAuth(
      apiKey: "<< my-okhi-api-key >>"
    );

    // only phone is required
    OkHiUser user = OkHiUser(
      phone: "+254712xxxxxx", 
      firstName: "John",
      lastName: "Doe"
    );

    return Scaffold(
      // add the below line to avoid keyboard padding issues
      resizeToAvoidBottomPadding: false,
      appBar: AppBar(
        title: Text('My App Bar'),
      ),
      body: OkHi(
        auth: auth,
        user: user,
        onSucess: (OkHiLocation location, OkHiUser user) {
          // handle success
        },
        onError: (error) {
          // handle errors
          print(error.message);
        },
        mode: OkHiLaunchMode.start_app,
      ),
    );
  }
}

CHANGELOG.md #

1.0.1 (23 July 2019) #

Fixes

  • Added changelog

example/README.md

import 'package:flutter/material.dart';
import 'package:okhi_flutter_widget/okhi_flutter_widget.dart';

class MyScreen extends StatelessWidget {
  @override
  Widget build(BuildContext context) {

    // make sure to have an apiKey before hand
    OkHiAuth auth = OkHiAuth(
      apiKey: "<< my-okhi-api-key >>"
    );

    // only phone is required
    OkHiUser user = OkHiUser(
      phone: "+254712xxxxxx", 
      firstName: "John",
      lastName: "Doe"
    );

    return Scaffold(
      // add the below line to avoid keyboard padding issues
      resizeToAvoidBottomPadding: false,
      appBar: AppBar(
        title: Text('My App Bar'),
      ),
      body: OkHi(
        auth: auth,
        user: user,
        onSucess: (OkHiLocation location, OkHiUser user) {
          // handle success
        },
        onError: (error) {
          // handle errors
          print(error.message);
        },
        mode: OkHiLaunchMode.start_app,
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  okhi_flutter_widget: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:okhi_flutter_widget/okhi_flutter_widget.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.47 points)

55 out of 56 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
meta ^1.1.6 1.1.7
webview_flutter ^0.3.10+3 0.3.15+1
Transitive dependencies
collection 1.14.11 1.14.12
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8