A simple MobX/Provider convience widget.
There are 6 generic variants of
Observing so that it's compatible with
Consumer. Any type may be used, not just mobx stores, as
long as they're provided as an ancestor to the
Observing widget of course.
In fact it works with
ChangeNotifierProvider as well for some real reactive
Provider( create: (context) => ViewModel(), child: Observing<ViewModel>( builder: (context, viewModel) => GestureDetector( onTap: viewModel.increment, child: Text( viewModel.value.toString(), key: key, textDirection: TextDirection.ltr, ), ), ), );
[0.0.1] - TODO: Add release date. #
- TODO: Describe initial release.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: observing: ^0.0.1
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jul 5, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.8.4
- pana: 0.13.13
- Flutter: 1.17.5
Package not compatible with SDK dart
because of import path [observing] that is in a package requiring null.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
observing.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.7.0 <3.0.0|