observable_state_lifecycle 0.4.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 45

observable_state_lifecycle #

Make Flutter StatefulWidget's lifecycle observable.

Getting Started #

When creating your StatefulWidget, add a mixin from this library:

// A Widget named Test

import 'package:observable_state_lifecycle/observable_state_lifecycle.dart';

class _TestState extends State<Test> with ObservableStateLifecycle<Test> {

}

Then you can call addLifecycleObserver in your state:

class _TestState extends State<Test> with ObservableStateLifecycle<Test> {
  _TestState() {
    addLifecycleObserver((phase){
      if(phase == StateLifecyclePhase.initState) {
        setState((){
          n = 2;
        });
      }
    });

    int n = 1;
  }
}

[0.0.1]

  • Initial commit

[0.0.2]

  • Fix didUpdateWidget

[0.1.0]

  • StateLifecycleSubject -> LifecycleSubject
  • StateLifecycleSubject() -> LifecycleSubject.create()

[0.2.0]

  • Callback instead of object

[0.3.0]

  • Remove state param from observer

[0.3.1]

  • Add ObserveState and ObserveEffect

[0.4.0]

  • Extract ObserveState and ObserveEffect into package active_observers

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  observable_state_lifecycle: ^0.4.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:observable_state_lifecycle/observable_state_lifecycle.dart';
  
Version Uploaded Documentation Archive
0.4.0 Mar 7, 2019 Go to the documentation of observable_state_lifecycle 0.4.0 Download observable_state_lifecycle 0.4.0 archive
0.3.1 Mar 7, 2019 Go to the documentation of observable_state_lifecycle 0.3.1 Download observable_state_lifecycle 0.3.1 archive
0.3.0 Mar 7, 2019 Go to the documentation of observable_state_lifecycle 0.3.0 Download observable_state_lifecycle 0.3.0 archive
0.2.0 Mar 7, 2019 Go to the documentation of observable_state_lifecycle 0.2.0 Download observable_state_lifecycle 0.2.0 archive
0.1.0 Mar 6, 2019 Go to the documentation of observable_state_lifecycle 0.1.0 Download observable_state_lifecycle 0.1.0 archive
0.0.2 Mar 6, 2019 Go to the documentation of observable_state_lifecycle 0.0.2 Download observable_state_lifecycle 0.0.2 archive
0.0.1 Mar 6, 2019 Go to the documentation of observable_state_lifecycle 0.0.1 Download observable_state_lifecycle 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Jun 26, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/observable_state_lifecycle.dart. (-0.50 points)

Analysis of lib/observable_state_lifecycle.dart reported 1 hint:

line 87 col 7: Set literals were not supported until version 2.2, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and observable_state_lifecycle.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test